1
$\begingroup$

I am trying to set up my qiskit environment but I seem to have run in trouble that I have no idea how to solve. I have installed the qiskit packages as can be seen by running pip list:

enter image description here

however whenever I try to import qiskit.visualization an error occurs:

enter image description here

and I don't understand why since it was suppose to be installed as qiskit module is installed. Any idea where this error comes from?

$\endgroup$
3
$\begingroup$

You are running a very old version of qiskit, I would recommending updating and this error should go away. You can do this by running pip install qiskit --upgrade

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Please see the edit. That was in fact the error, but as usual, another has come up $\endgroup$ – Bidon Mar 4 at 15:49
  • $\begingroup$ Hi! Please remove the edit and ask it as a separate question as it is unrelated to the original question :) $\endgroup$ – met927 Mar 4 at 15:50
  • 1
    $\begingroup$ Will do, thank you. quantumcomputing.stackexchange.com/q/10088/5620 $\endgroup$ – Bidon Mar 4 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.