0
$\begingroup$

I believe I have installed qiskit on my computer. Running pip list or pip3 list in terminal returns:

qiskit                   0.26.0
qiskit-aer               0.8.2
qiskit-aqua              0.9.1
qiskit-ibmq-provider     0.13.1
qiskit-ignis             0.6.0
qiskit-terra             0.17.3

However when I then open a jupyter notebook and try

import qiskit

I get told that there is no module named qiskit available. Does anyone know what I am doing wrong?

$\endgroup$
1
  • $\begingroup$ Did you ever resolve this? I had the same problem, and the below answer didn't work for me. Instead, I found another answer here on StackExchange that solved this issue: quantumcomputing.stackexchange.com/a/15591/15981 I'm new to all this, so forgive me if I butcher the explanation, but basically Jupyter is not starting a kernel within your new environment you made for QISKIT, so you need to set it up to give you the option to create notebooks within that environment. $\endgroup$ – Hee Jin May 23 at 23:47
0
$\begingroup$

So I found the answer on the qiskit slack channel and thought I would post here in case someone else comes across the same issue. I did not have jupyter installed in the same environment where qiskit was installed. Just running pip install jupyter and restarting the terminal worked for me

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.