2
$\begingroup$

I am trying to use the statevector_gpu simulation method in Qiskit Aer (see this page). I installed qiskit-aer-gpu according to the instructions on this page. It was working last week and then stopped working. I'm not sure what changed. (It's a shared computer.) I get the error message qiskit.providers.aer.aererror.AerError: "Invalid simulation method statevector_gpu. Available methods are: ['automatic', 'statevector']".

Thanks in advance for the help!

Here is the relevant system information:

  • It is a shared computer running Ubuntu 18.04.4 LTS.
  • I have qiskit 0.23.0, qiskit-aer 0.7.0, qiskit-aer-gpu 0.7.0 installed in an environment in conda 4.8.5 with python 3.8.5.
  • nvcc --version gives Cuda compilation tools, release 10.0, V10.0.130
  • nvidia-smi shows 4 GPUs available and indicates CUDA Version: 10.2.
$\endgroup$
2
$\begingroup$

The qiskit-aer and qiskit-aer-gpu are mutually exclusive packages. They contain the same code except that the qiskit-aer-gpu package built with CUDA support enabled. If you install both packages at the same time the contents of the 2 packages will interfere with each other. I would recommend creating a new conda environment and installing qiskit-terra and qiskit-aer-gpu manually with pip install -U qiskit-terra qiskit-aer-gpu (and add qiskit-ignis, qiskit-aqua, and qiskit-ibmq-provider if they're needed). If you still have issues with only qiskit-aer-gpu installed in the environment please file an issue at https://github.com/Qiskit/qiskit-aer/issues and we can work on debugging it there.

| improve this answer | |
$\endgroup$
  • $\begingroup$ That fixed it, thanks!! $\endgroup$ – Eliott Rosenberg Oct 30 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.