2
$\begingroup$

I am attempting to mitigate measurement error while running on one of IBM's real devices and am doing so by passing CompleteMeasFitter into measurement_error_mitigation_cls in QuantumInstance. However, when I run the program, I receive the following error:

qiskit.aqua.aqua_error.AquaError: 'The qubit mapping of circuits are different. 
Currently, we only support single mapping.'

I can see that the problem is coming from get_measured_qubits_from_qobj in measurment_error_mitigation.py. After a few iterations, the measured_qubits and qubit_mapping are not equal. I figured that the problem could be arising from the transpiler since the default optimization level is 1, meaning it will optimize based on connectivity. So, I tried changing optimization_level to 0 in quantum instance in hopes that qubit_mapping and measured_qubit will not be different, but have not had any luck.

How can I go about fixing this problem?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.