2
$\begingroup$

I cobbled together a few programs with Qiskit several months back which worked fine on both the BasicAer simulators and the actual IBMQ computers. However, when I tried to revisit them recently, executing on the actual quantum computers ran into issues because no computers would appear in IBMQ.backends(). After testing, it seems that while I can save an account (and I have successfully overwritten my old accounts with a new API key), loading accounts runs into an issue and throws the following error:

"ConnectionError: Couldn't connect to IBMQ server: error during login: License required. You need to accept the License from Web Platform. https://quantumexperience.ng.bluemix.net"

However, the link redirects me to the new website and I've accepted the most recent license agreement there. The closest answer I've found seems to indicate that I need to manually input a new URL, but it doesn't actually provide what that URL is. Instead it suggests copying it from a button that I can't find at the linked page.

If I'm barking up the wrong tree with the solution to my error, I'd love if someone could set me straight. If I'm on the right track, where in the world do I find the new URL?

$\endgroup$
1
$\begingroup$

If you have defintely accepted the license agreement then the case is usually the credentials haven't updated locally. Try generating a new API token on the website and then run :

IBMQ.delete_account()
IBMQ.save_account(APITOKEN, overwrite=True)
IBMQ.load_account()

This should clear up anything that could possibly still be around linked to your old credentials and replace it with credentials to point to the new API.

$\endgroup$
  • $\begingroup$ I just ran IBMQ.delete_accounts(), checked that there were no saved accounts (there weren't), and ran IBMQ.save_account() with a regenerated API token and overwrite=true. That properly saved, but IBMQ.load_account() still threw the error I mentioned above. The URL associated with the API token is still the same as it was. $\endgroup$ – QBurner52 Oct 9 at 23:24
  • $\begingroup$ @QBurner52, what version of Qiskit are you running? $\endgroup$ – Matthew Stypulkoski Oct 10 at 17:50
  • $\begingroup$ @MatthewStypulkoski I'm running 0.5.5 $\endgroup$ – QBurner52 Oct 10 at 19:30
  • $\begingroup$ Which element of qiskit is this? You can see all of your elements' versions by running: import qiskit and then calling qiskit.__qiskit_version__ $\endgroup$ – Matthew Stypulkoski Oct 10 at 21:50
  • 1
    $\begingroup$ Ah, I didn't realize that qiskit itself had to be updated separately from the VSCode extension. I'm able to load my account and find backends now, though only by executing in the terminal (just "run Python" yields errors that are too large to fully display, and debugging doesn't run into them). That, however, should be a separate question, I believe. Thank you for your help! $\endgroup$ – QBurner52 Oct 11 at 5:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.