2
$\begingroup$

The following statement is causing an error in Qiskit Version 0.9.0:

provider = IBMQ.load_account()

Error Message:

IBMQAccountError: 'IBM Q Experience v1 credentials found. Please update your accounts and programs by following the instructions here:\nhttps://github.com/Qiskit/qiskit-ibmq-provider#updating-to-the-new-ibm-q-experience'

The display of the account finformation from the stored location is working OK and matches the API key:

print(str(IBMQ.stored_account())) 

{'token': '94....051', 'url': 'https://auth.quantum-computing.ibm.com/api'}

When using the provider = IBMQ.load_account("94....051"), the authentication completed normally. I've already tried to manually delete the registry with rm ~/.qiskit/qiskitrc, or by using the IBMQ.delete_account() command, or by doing the IBMQ.update_account(), as well as doing a refresh of the token. The error persist at the the load_account() function.

Versions used:

0.9.0
{'qiskit-terra': '0.9.0', 'qiskit-ignis': '0.2.0', 'qiskit-aqua': '0.6.0', 'qiskit': '0.12.0', 'qiskit-aer': '0.3.0', 'qiskit-ibmq-provider': '0.3.2'}
$\endgroup$
  • 1
    $\begingroup$ Thanks for the quick reply and answer. Indeed, the overwrite flag on the save_account command solved the issue together with an update of the API key. Possibly the error was part of my release upgrade process, or some "cached" class in Anaconda. Its solved and the authentication is working now. $\endgroup$ – Claude Falbriard Sep 4 at 17:12
2
$\begingroup$

This error means that old credentials are still in use on your disk. Try getting a new API key from the website and then running IBMQ.save_account('APIKEY', overwrite=True). This should overwrite the existing old credentials with new ones.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.