0
$\begingroup$

I recently made a quantum circuit that uses 32 qubits and try to run it on IBM Q Experience qasm_simulator backend. But it always ends with ERROR_RUNNING_JOB.

When i retrieve the job and display the error, i only got

"The following experiments failed:\n" without any details.

How i can get more information about the error?

The following is my qiskit version information:

{'qiskit': None, 'qiskit-terra': '0.8.0', 'qiskit-ignis': '0.1.1', 'qiskit-aer': '0.2.0', 'qiskit-ibmq-provider': '0.2.2', 'qiskit-aqua': '0.5.2'}

According to @Bram suggestion i run

$ pip install qiskit
Building wheels for collected packages: qiskit, qiskit-ibmq-provider
  Building wheel for qiskit (setup.py) ... error
  Complete output from command /home/userName/anaconda3/envs/quantum/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-kavivdyx/qiskit/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/pip-wheel-eak_06_d --python-tag cp37:
  running bdist_wheel

  ----------------------------------------
  Failed building wheel for qiskit
  Running setup.py clean for qiskit
  Building wheel for qiskit-ibmq-provider (setup.py) ... done
  Stored in directory: /home/userName/.cache/pip/wheels/0c/56/e7/b07b4d2f19fd4c5fff7fe334c72eb313fecf04fa693a7c558e
Successfully built qiskit-ibmq-provider
Failed to build qiskit
Installing collected packages: qiskit-terra, qiskit-aer, nest-asyncio, qiskit-ibmq-provider, pyscf, qiskit-chemistry, qiskit, more-itertools
  Found existing installation: qiskit-terra 0.8.0
    Uninstalling qiskit-terra-0.8.0:
      Successfully uninstalled qiskit-terra-0.8.0
  Found existing installation: qiskit-aer 0.2.0
    Uninstalling qiskit-aer-0.2.0:
      Successfully uninstalled qiskit-aer-0.2.0
  Found existing installation: qiskit-ibmq-provider 0.2.2
    Uninstalling qiskit-ibmq-provider-0.2.2:
      Successfully uninstalled qiskit-ibmq-provider-0.2.2
  Running setup.py install for qiskit ... done
  Found existing installation: more-itertools 6.0.0
    Uninstalling more-itertools-6.0.0:
      Successfully uninstalled more-itertools-6.0.0
Successfully installed more-itertools-5.0.0 nest-asyncio-1.0.0 pyscf-1.6.2 qiskit-0.11.0 qiskit-aer-0.2.3 qiskit-chemistry-0.5.0 qiskit-ibmq-provider-0.3.0 qiskit-terra-0.8.2

From this output i notice that wheel was failed in build, does that cause any problems?

I then run

$conda list | grep qiskit
qiskit                    0.11.0                   pypi_0    pypi
qiskit-aer                0.2.3                    pypi_0    pypi
qiskit-aqua               0.5.2                    pypi_0    pypi
qiskit-chemistry          0.5.0                    pypi_0    pypi
qiskit-ibmq-provider      0.3.0                    pypi_0    pypi
qiskit-ignis              0.1.1                    pypi_0    pypi
qiskit-terra              0.8.2                    pypi_0    pypi
enter preformatted text here

and run the following in IPython console

>>import qiskit
>>qiskit.__qiskit_version__
Out[2]: 
{'qiskit': '0.11.0',
 'qiskit-terra': '0.8.2',
 'qiskit-ignis': '0.1.1',
 'qiskit-aer': '0.2.3',
 'qiskit-ibmq-provider': '0.3.0',
 'qiskit-aqua': '0.5.2'}

i will send another job and wait for the result.

Edit: The same error , ERROR_RUNNING_JOB, still occur, appear after the above update.

$\endgroup$
  • $\begingroup$ Installation is fine, wheel failure is not an problem, Did you try another standard example? ERROR_RUNNING_JOB could also mean a wrong line in youre code. Also the credentials needs to be set. $\endgroup$ – Bram Jul 21 at 20:29
  • $\begingroup$ @Bram If you mean IBMQ credentials of course i set them. I tried a smaller circuit with 28 qubit and it works without errors. The 32 qubit circuit use another subcircuit that is tested and used in the 28 quibt circuit. $\endgroup$ – Abdalla Essam Ali Jul 22 at 4:34
  • $\begingroup$ Hi, can you provide some more information about the circuit you are running and the parameters you are using to submit it? $\endgroup$ – met927 Aug 5 at 11:56
0
$\begingroup$

You're qiskit information shows 'qiskit': None. This should be 0.11 or smaller. Furthermore qiskit-ibmq-provider : 0.2.2 should be 0.3 for the latest version.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.