2
$\begingroup$

I am noticing some erroneous behavior coming from the visualizer in some circuits I was running. I am not sure how widespread the issue is, but see the attached image for some strange behavior with the cZ gate.

Is there a place to see the matrix each gate is implementing like before?

Has anyone found similar issues?

This issue does not persist when I actually click "run" and select simulator. It seems to only affect the visualizer.

enter image description here

$\endgroup$
  • $\begingroup$ Just to confirm, the issue is that the cZ gates are changing the expected probabilities, even though they should not have any affect in this case? $\endgroup$ – Matthew Stypulkoski Jun 10 at 14:12
  • $\begingroup$ That's correct, both the probabilities as well as the actual state (which is what's shown in the picture). I didn't check the density matrix. Control is 0 so each should implement the identity, furthermore two of them in a row should implement the identity regardless of the state of the control. $\endgroup$ – bRost03 Jun 10 at 14:20
3
$\begingroup$

Thank you for pointing out this! The matrix of the cZ gate has been corrected in the in-browser simulator for the visualizations. Simply retry by refreshing your browser.

$\endgroup$
  • $\begingroup$ Thank you! How about the other part of the question, "Is there a place to see the matrix each gate is implementing like before?". Also, while I've got your ear, is there a way to see my job's position in the queue when running on actual hardware? $\endgroup$ – bRost03 Jun 11 at 9:36
  • 1
    $\begingroup$ @bRost03 both things will eventually get into the new IBM Q Experience, stay tuned! $\endgroup$ – Fran Cabrera Jun 11 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.