1
$\begingroup$

I have updated qiskit module but unfortunately, it doesn't work it says

C:\Users\Aman\AppData\Local\Programs\Python\Python36-32
\lib\site-packages\marshmallow\schema.py:364: 
ChangedInMarshmallow3Warning: strict=False is not recommended. 

In marshmallow 3.0, schemas will always be strict. See 
https://marshmallow.readthedocs.io/en/latest/upgrading.html
#schemas-are-always-strict ChangedInMarshmallow3Warning

What shall I do?

$\endgroup$

1 Answer 1

3
$\begingroup$

This is a Just a Python warning about deprecated usage. It will be fixed in the next release. It should not prevent you from upgrading Qiskit or writing any code today.

$\endgroup$
3
  • 1
    $\begingroup$ I used 'pip install -U qiskit' then everything goes wrong. And I can't run my code!!!! $\endgroup$
    – Aman
    Commented Feb 11, 2019 at 9:06
  • 1
    $\begingroup$ Can you you post your code or any other errors you're seeing? $\endgroup$
    – Leron Gil
    Commented Feb 11, 2019 at 17:18
  • $\begingroup$ I found it. it is just the plot_histogram function doesn't work. When I change it to the print it works fine!! Thank You!! $\endgroup$
    – Aman
    Commented Feb 18, 2019 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.