3
$\begingroup$

I am currently running the following document from this Qiskit documentation.

This notebook is running in Jupyter, and I started Jupyter from the Mac terminal within a Conda environment. Normally, this works fine with Qiskit. The problem is that when I run the command:

ae._circuit.draw(output='latex')

I get the following error:

WARNING: Unable to compile latex. Is 'pdflatex' installed? Skipping latex circuit drawing...

I tried conda install pdflatex and many variations of this, but nothing worked so far. Does anyone know how to solve this problem?

$\endgroup$
3
$\begingroup$

You are missing the pdflatex binary. Install pdflatex from your OS's LaTeX installer. For MacOS, follow this link: Where do I get the pdflatex program for Mac?.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.