Qiskit Finance version: 0.5.0

Python version: Using the Qiskit Lab v1.0.0

Operating system: Windows 11

Hi, technically I am new to this quantum computing stuff. I see that an upgrade of Qiskit to 1.0 was made, and that this pretty much removed the qiskit.extensions. However, in the Qiskit_finance repository trying to make the tutorial, they say it runs even for this new version of Qiskit.

I am trying with tutorial 09_credit_risk_analysis.ipynb but in this part:

from qiskit_finance.circuit.library import GaussianConditionalIndependenceModel as GCI

u = GCI(n_z, z_max, p_zeros, rhos)

It should extract a Gaussian function previously located in qiskit_finance.circuit.library

I get the error in the title. Is there something I need to install?


1 Answer 1


Qiskit Finance has been updated in its repository with some compatibility fixes for the recently released Qiskit 1.0, but an official release has yet to be done that contains these fixes. For now you would have to install Qiskit Finance from source from the main branch there, or revert to the earlier 0.46 Qiskit.

  • $\begingroup$ The best is to make a virtual environment and in that venv, fix the versions of your installs like %pip install qiskit==0.46.0 and qiskit_finance as well $\endgroup$ Feb 25 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.