1
$\begingroup$

In particular I try to find out which version of qiskit is compatible with which version of qiskit-ibm-runtime. In my setup right now, both need different versions of qiskit-aer and qiskit-ibmq-provider or qiskit-ibm-provider. For qiskit there is this documentation. Is there something similar for qiskit-ibm-runtime? Or ideally a list of compatibilities among the qiskit packages? Or can I retrieve the info using pip without installing the packages?

Edit: To make it more clear, I am looking for the information " qiskit-ibm-runtime version x will have no conflicting dependencies with qiskit version y."

$\endgroup$

3 Answers 3

1
$\begingroup$

If you know where to find the repositories in GitHub you can look at the associated requirement files. So for qiskit-ibm-runtime you can look at https://github.com/Qiskit/qiskit-ibm-runtime/blob/main/requirements.txt and see that the current version has the following qiskit version requirements

  • qiskit-terra>=0.25.0
  • qiskit-ibm-provider>=0.6.3

You will need to pay attention to what version of the repo matches the release you are using if you did a "pip install" instead of cloning the repository.

$\endgroup$
1
$\begingroup$

Not sure if I understand the problem you are having. Here some random ideas:

$\endgroup$
1
  • $\begingroup$ Thanks for the suggestions. pipdeptree and pip check help to find conflicting dependencies more easily. But I am looking for a list of dependencies for each version of the two packages to find a combination that has no conflicts. Like wheelodox but for all versions, not only the latest. $\endgroup$ Commented Aug 14, 2023 at 9:23
0
$\begingroup$

I use poetry for managing dependencies, and in my case this issue could be resolved by manually setting the qiskit version with poetry add qiskit@^1.0.0, then poetry add qiskit_ibm_runtime. The version of qiskit_ibm_runtime installed due to this was ^0.23.0. Before changing the qiskit version manually, I got the error message:

Because no versions of qiskit-ibm-runtime match >0.23.0,<0.24.0 and qiskit-ibm-runtime (0.23.0) depends on qiskit (>=1.0.0), qiskit-ibm-runtime (>=0.23.0,<0.24.0) requires qiskit (>=1.0.0).

Which seems to me to represent a case similar to your problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.