0
$\begingroup$

I have been working with on some research on tensorflow, tensorflow-quantum and tensorflow-federated and the problem with that is I just can't install those three at my google colab and I tried different version and asked the tensorflow community but there is no answer regarding this topic. So, any help will be highly appreciated.

$\endgroup$
6
  • $\begingroup$ There's a full working Tensorflow environment available on qBraid Lab. Can't guarantee the same package versions will work for your local OS, but they use tensorflow==2.7.0, tensorflow-quantum==0.7.2, and cirq-core==0.13.1, but don't seem to have tensorflow-federated included in that. $\endgroup$
    – ryanhill1
    Mar 20, 2023 at 20:35
  • $\begingroup$ it's really sad I tried several versions for my research and still getting error 😑... is there any way that I can build package from source code in anaconda? $\endgroup$
    – Rayhan
    Mar 23, 2023 at 11:19
  • $\begingroup$ I'm not sure, but have you tried using it on qBraid? It's free and it should work $\endgroup$
    – ryanhill1
    Mar 24, 2023 at 13:59
  • $\begingroup$ yes I tried but federated didn't worked. $\endgroup$
    – Rayhan
    Mar 31, 2023 at 14:23
  • $\begingroup$ Did you try adding federated by installing it in the notebook? Or did that also break? See docs.qbraid.com/en/latest/lab/… $\endgroup$
    – ryanhill1
    Mar 31, 2023 at 14:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.