1
$\begingroup$

This is the first time I am using the IBM quantum computer. I tried to run a circuit (see below the first picture) but the results I got don't match the theoretical results shown (see below the second picture). I am honestly not sure what to do or why this happens. I also tried to run different circuits but they seem to have to same problem so I am probably misinterpreting something. I also tried to use a different quantum processor but they give the same problem.

Thanks in advance.

enter image description here

$\endgroup$
0
$\begingroup$

This happens because the effect of measuring a qubit. Half of the time, the qubit $q_0$ collapses to $1$, half of the time to $0$.

In your first example, $q_0$ collapsed to $1$, so your theoretical chances (from the second example) of $*0$ are distributed among $01$ and $11$.

You can see that if you change the Visualisation seed on the top right corner. Here is an example with seed = 1726:

same example with seed 1726"

In this case, $q_0$ collapsed to $0$ and $*1$ is not happening now. As a consequence, the only possible result is $00$, since $10$ was never a possibility (even without the measurement).

$\endgroup$
2
  • $\begingroup$ Thanks for the responds. I had no idea about the visualisation seed. As I understand it now this is only used to determine the 'theoretical' results right? Does this impact the results when I run the the circuit on a quantum processor? $\endgroup$ – Audrique May 12 at 11:43
  • $\begingroup$ when you run in the real device, the default is to run the circuit 1024 times. So you will have the histogram close to your paper result. $\endgroup$ – luciano May 12 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.