0
$\begingroup$

I've already tried the instructions on the qiskit page and even from this other question What is the location of the Qiskit config file? but it doesn´t work, the circuit keeps looking as text based, even i restarted jupyter notebook, and nothing. The settings.conf file wasn't in the directory so i created one but still no results.

$\endgroup$
4
  • 1
    $\begingroup$ I’m voting to close this question because it's a question about a specific python package/functionality and has nothing to do with QC or quantum mechanics per se $\endgroup$
    – glS
    Mar 10 at 11:40
  • $\begingroup$ Does it have to be about quantum mechanics? The questiin is about qiskit and is more likely to be answered here than elsewhere. $\endgroup$ Mar 10 at 15:14
  • $\begingroup$ This is not a difficult problem, I think. Try circ.draw('mpl') and then `plt.show()'. But you really need to describe the situation specifically because it is not clear what really happens. $\endgroup$ Mar 11 at 6:49
  • $\begingroup$ the problem is that i want qiskit to plot on mpl by default the circuits and so, but following the instructions of it makes no changes, like if qiskit wasn't able to recognize the settings file or something like that $\endgroup$ Mar 12 at 23:59
2
$\begingroup$

To check that the content of the setting.conf file is properly set you can run the following

from qiskit import user_config
user_config.get_config()
{'circuit_drawer': 'mpl'}

If this is not your output, then your setting.conf is out of format or in the wrong location. You can fix the location by setting the env variable QISKIT_SETTINGS. It is possible to do that in a Jupyter notebook with this magic:

%env QISKIT_SETTINGS <path to your setting.conf>
$\endgroup$
6
  • $\begingroup$ still no changes, first recalling the qisikit user_config but the output gives nothing, then i tried the env variable and again recalling the user_config but gives again nothing $\endgroup$ Mar 10 at 20:54
  • $\begingroup$ are you on windows? $\endgroup$
    – luciano
    Mar 10 at 20:57
  • $\begingroup$ yeah, ive also tried to put it on .ini format but nothing $\endgroup$ Mar 10 at 21:02
  • $\begingroup$ what is output of user_config.DEFAULT_FILENAME? Could try editing that if it isn't what you expected $\endgroup$
    – Frank
    Mar 11 at 12:49
  • $\begingroup$ the command is not recognized on the conda prompt $\endgroup$ Mar 12 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.