2
$\begingroup$

I am attempting to setup a PyCharm project to study and work through the QISKit textbook. However I seem to be running into a propblem seting it up.

I have setup a python enviroment via anaconda (PyCharm does this automatically). I run pip install qiskit which returns the Failed buidling wheel for h5py error but I read online that this can be ignored.

I tried to import from qiskit but got an error saying ther is no reference to qiskit.

I tried the auto fix of installing the qiskit package again but it had an error displayed in the below screenshot.

Help would be appreciated in setting up my PyCharm project.

Many thanks. enter image description here enter image description here enter image description here enter image description here

$\endgroup$
5
  • $\begingroup$ Turns out qiskit is not in the list of installed packages, hence the wheel error cannot be ignored. I get an error about it being unable to load dependency HDF5. $\endgroup$
    – Ray117
    Feb 26, 2021 at 17:53
  • 1
    $\begingroup$ I’m voting to close this question because it's a purely programming question unrelated to quantum computing $\endgroup$
    – glS
    Mar 1, 2021 at 20:17
  • 3
    $\begingroup$ I’m voting to close this question because it is not about quantum computing (similarly to how "biopython not installing in pycharm" would not be a question about biology). $\endgroup$ Sep 4, 2021 at 16:26
  • 1
    $\begingroup$ I'm voting to keep this question open because I think this community (QCSE) is still the best SE community to answer this question. We have the largest density of Qiskit users, and the people who will be interested enough in the question. Qiskit is currently our 2nd most popular tag. On another note, I'm surprised the question hasn't been answered yet, and maybe it could be closed for a different reason such as "needs details for clarity". However that error message looks like it's due to some missing packaged, and the failure of h5py (HDF5 for python) to get built. Maybe not hard to solve $\endgroup$ Sep 5, 2021 at 2:50
  • $\begingroup$ I had no issue installing Qiskit with the latest versions of Python and pip on an Ubuntu system, and was able to access the virtual environment through PyCharm. What version of Python are you using? Also, its an unusual procedure, but qiskit seems to recommend making a fresh conda environment and then installing into that environment with pip, rather than conda. The error message in your first image suggests it is trying to install qiskit with conda, which I don't think would be possible. $\endgroup$
    – Tyberius
    Sep 6, 2021 at 20:06

0

Browse other questions tagged or ask your own question.