2
$\begingroup$

I'm transpiling a set of quantum circuits using ibmq_5_yorktown. However, as the number of circuits gets larger, it shows me the following error message:

TranspilerError: 'Maximum iteration reached. max_iteration=1000'

How can I fix this issue? Is it still possible for me to transpile more than 1,000 circuits? Thanks!

$\endgroup$
7
  • 1
    $\begingroup$ Not sure what this error was... I ran into this same error earlier but rerun my experiement and everything was fine. I haven't had the chance to look into this in details but I created a set of circuits with 1100 circuits and transpiled with no problem... of course, running it on the device would be an issue since you can't submit more than 900 onto the hardware. $\endgroup$ – KAJ226 Feb 16 at 4:43
  • $\begingroup$ @KAJ226 Thanks for the comment! Which quantum computer did you use? $\endgroup$ – ZR- Feb 16 at 5:56
  • 1
    $\begingroup$ I used ibmq_athens $\endgroup$ – KAJ226 Feb 16 at 6:01
  • 3
    $\begingroup$ It seems like a known problem github.com/Qiskit/qiskit-terra/issues/5832 . The problems is not the amount of circuits, but the fact that the optimization iteration is looping without control. $\endgroup$ – luciano Feb 16 at 7:18
  • 1
    $\begingroup$ can you tell us more about the circuit and the backend you are running? $\endgroup$ – luciano Feb 19 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.