2
$\begingroup$

I'm coding using the Jupyter Notebook in the IBM Quantum Lab. However, I don't know why I see the following repeated message every time when I execute a quantum circuit: enter image description here

This message shows thousands of times and occupied a significant amount of memory. However, it shows that the job I submitted could be successfully executed, but I'm not able to access the result. enter image description here

Does anyone know what happened? What can I do to fix this issue? Thanks a lot!

$\endgroup$
5
  • $\begingroup$ I use the Notebook in Quantum Lab because it has a more up to date Python version so that some issues such as 'BrokenProcessPool' error could be avoided:) $\endgroup$
    – ZR-
    Feb 5 at 6:27
  • $\begingroup$ Has anyone encountered similar issues? $\endgroup$
    – ZR-
    Feb 5 at 6:49
  • 1
    $\begingroup$ Hi, btw normally the latest version of Qiskit (0.23.4) now supports the version 3.9 of python if you wish to work locally ;) $\endgroup$
    – Lena
    Feb 5 at 9:03
  • $\begingroup$ @Lena Thanks!! By 'locally', do you mean working on the regular notebook or IBM Q Lab? $\endgroup$
    – ZR-
    Feb 5 at 16:37
  • 1
    $\begingroup$ I mean on regular notebook $\endgroup$
    – Lena
    Feb 5 at 16:59
3
$\begingroup$

NumPy 1.20 is deprecating part of their API. You have three options:

  • Wait for the next Qiskit release (0.24). It should be around the corner (the PR fixing this was merged already).
  • Downgrade NumPy running !pip install numpy==0.19 in the notebook and restart it.
  • Ignore warnings:
import warnings
warnings.filterwarnings('ignore')
$\endgroup$
5
  • $\begingroup$ Thanks a lot for the answer! Unfortunately the third option doesn't work for me. By waiting for the next Qiskit release, do you mean waiting for the new version? $\endgroup$
    – ZR-
    Feb 5 at 6:47
  • $\begingroup$ Indeed. This will be solved in qiskit-0.24 as the PR to fix the issues was already merged. github.com/Qiskit/qiskit-terra/pull/5758 $\endgroup$
    – luciano
    Feb 5 at 8:01
  • $\begingroup$ oh! I missed the part in where you said you are running in the Quantum Lab. I just adapted the answer to it (run pip install in the notebook with the bang). $\endgroup$
    – luciano
    Feb 5 at 8:14
  • $\begingroup$ Can I downgrade the Numpy in Q Lab? I tried that command with the bang but it doesn't work. $\endgroup$
    – ZR-
    Feb 5 at 17:30
  • $\begingroup$ you can. What's the error? $\endgroup$
    – luciano
    Feb 5 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.