1
$\begingroup$
qiskit.providers.ibmq.exceptions.IBMQBackendApiError: 'Error submitting job:....

(Caused by SSLError(SSLError(1, \'[SSL: 
WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1056)....

I used a basic Qiskit tutorial within a Conda environment, Python3.7, Ubuntu 18. The was no problem getting it to load account with token and display the following:

ibmq_qasm_simulator has 0 queued and simulated qubits
ibmqx2 has 241 queued and 5 qubits
ibmq_16_melbourne has 3681 queued and 15 qubits
ibmq_vigo has 393 queued and 5 qubits
ibmq_ourense has 507 queued and 5 qubits
ibmq_valencia has 0 queued and 5 qubits
ibmq_armonk has 3 queued and 1 qubits
ibmq_athens has 13 queued and 5 qubits
ibmq_santiago has 17 queued and 5 qubits

This is the section of code which generated the error:

from qiskit.tools.monitor import job_monitor
backend = provider.get_backend('ibmq_qasm_simulator')
config = backend.configuration()
job = q.execute(circuit, backend, shots=10)
job_monitor(job)

I found one reference to the issue being on their cloud and it suggested using a VPN or different Network. I also setup an IBM cloud account, but there does not appear to be a way to incorporate that into qiskit. The next thing I tried was seeing if the IP address of their cloud link being called would work just in a simple browser window along the lines of a suggestion about safe.io intercepting the SSL on Macs.

I also tried a few things related to OpenSSL and reinstalling that bit etc... no luck. The qiskit package was installed using PIP within Conda.

QisKit Version:
qiskit-terra: 0.16.1
qiskit-aer: 0.7.1 
qiskit-ignis: 0.5.1 
qiskit-ibmq-provider: 0.11.1
qiskit-aqua: 0.8.1 
qiskit: 0.23.1 
$\endgroup$
  • 1
    $\begingroup$ Can you also include your qiskit version? from qiskit import __qiskit_version__ $\endgroup$ – luciano Dec 9 '20 at 8:09
  • $\begingroup$ qiskit-terra: 0.16.1, qiskit-aer: 0.7.1, qiskit-ignis: 0.5.1, qiskit-ibmq-provider: 0.11.1, qiskit-aqua: 0.8.1, qiskit: 0.23.1 (thank you for the help) $\endgroup$ – Preston Dec 9 '20 at 13:01
1
$\begingroup$

This is duplicate of Error while trying to execute the Quantum Circuits in IBMQ

My answer from the other post:

This is caused by safebrowse.io blocking the url and sending back a http response (which the client interpreted as a TLS version it didn't understand). Unfortunately safebrowse.io doesn't allow whitelisting a single url, so you'll need to disable it entirely. Here’s a link on how to do it: https://howtoremove.guide/safebrowse-io-virus/#:~:text=What%20is%20Safebrowse.io%3F,compromise%20their%20system%20and%20privacy

$\endgroup$
  • $\begingroup$ I do appreciate your help. I did try testing the link in a browser window, and as I mention above, there is no direction to safesearch.io (and this is not a Mac), just an error about trying to log in without a token which would be expected. I will check the ISP logs and try out what you suggest. Thank you. $\endgroup$ – Preston Dec 9 '20 at 13:34
  • $\begingroup$ JYU00 was exactly correct. Checking the ISP logs, the IBM cloud site had been blocked due to "Phishing/Fraud" flag. Disabling this allowed the job to run with no problem and no SSL error. Thank you. $\endgroup$ – Preston Dec 9 '20 at 13:53
  • $\begingroup$ @Preston I'm glad it's working now. If you are using Windows can you post the steps you took to resolve the issue? That'd help others that also use Windows (I only have a Mac so I can't really help here). $\endgroup$ – jyu00 Dec 9 '20 at 18:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.