1
$\begingroup$

When I run IBMQ.load_account(). I have the error information:

C:\application\python\anaconda\lib\site-packages\qiskit\providers\ibmq\ibmqfactory.py:192: UserWarning: Timestamps in IBMQ backend properties, jobs, and job results are all now in local time instead of UTC.
warnings.warn('Timestamps in IBMQ backend properties, jobs, and job results '
ibmqfactory._initialize_providers:WARNING:2020-09-21 15:33:39,682: Unable to instantiate provider for {'hub': 'ibm-q-research', 'group': 'Cheng-Guo', 'project': 'main'}: string indices must be integers.

I want to ask about the second warning:Unable to instantiate provider for {'hub': 'ibm-q-research', 'group': 'Cheng-Guo', 'project': 'main'}: string indices must be integers.

My account have two provider: (hub='ibm-q', group='open', project='main') {hub: 'ibm-q-research', group: 'Cheng-Guo', project: 'main'}

I can only use first provider locally. Because of this two question:"https://quantumcomputing.stackexchange.com/questions/12183/ibmqfactory-initialize-providers-error" and "https://quantumcomputing.stackexchange.com/questions/13350/qiskit-ibmq-load-account-fails-on-version-0-20-0".

I have tried to delete my account then save it. But it didn't work. I have tried to use qiskit 0.21.0, the newest version in github. But it didn't work. I have tried to use qiskit 0.20.1, the version in Quantum Lab(https://quantum-computing.ibm.com/jupyter). But it didn't work.

The same version of qiskit (0.20.1) cannot be used locally but can be used in quantum lab, so I can only use quantum lab to program now. But quantum lab requires network connection, which is not very convenient.

I have tried to change a PC and install qiskit(version 0.21.0 in default), it didn't work.

I have read the source code and I still can't understand why only the research provider don't work, and only don't work locally.

Thank you very much if you can help me.

$\endgroup$
  • $\begingroup$ What qiskit version do you get when you run qiskit.__qiskit_version__ after importing qiskit? Also, for the account token, I would try running IBMQ.delete_account() and then IBMQ.save_account(<token>, overwrite=True). $\endgroup$ – Winona Sep 21 at 16:19
  • $\begingroup$ As I said in the description, I have tried two versions of qiskit (0.20.1 and 0.21.0), and also tried to delete the account. Unfortunately, it didn't work. $\endgroup$ – wei zi Sep 22 at 1:43
  • $\begingroup$ Ok, I'm sorry about that. When you do load your account, what do you get when you run IBMQ.providers()? $\endgroup$ – Winona Sep 22 at 13:27
  • $\begingroup$ When you run qiskit.__qiskit_version_ it will print out the versions for all of the qiskit elements (terra, ignis, aqua, aer, ibmq-provider). We should confirm that all of the qiskit versions are up to date, because this issue could be caused by a mismatch of versions involving the ibmq-provider. $\endgroup$ – Matthew Stypulkoski Sep 22 at 13:57
  • $\begingroup$ @Winona. Thanks for care. I only have [<AccountProvider for IBMQ(hub='ibm-q', group='open', project='main')>] when I run IBMQ.providers() $\endgroup$ – wei zi Sep 23 at 5:33
0
$\begingroup$

Please contact your hub Group Admin to confirm that the email address of the IBM Quantum Experience account you are using has access to this Group.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I see your email, thank you very much! $\endgroup$ – wei zi Sep 24 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.