-1
$\begingroup$

When running pip show qiskit-ibmq-provider in the Anaconda Prompt I get the following:

Name: qiskit-ibmq-provider
Version: 0.8.0
Summary: Qiskit provider for accessing the quantum devices and simulators at IBMQ
Home-page: https://github.com/Qiskit/qiskit-ibmq-provider
Author: Qiskit Development Team
Author-email: qiskit@qiskit.org
License: Apache 2.0
Location: c:\users\user\appdata\roaming\python\python37\site-packages
Requires: python-dateutil, urllib3, numpy, websockets, qiskit-terra, requests, requests-ntlm, nest-asyncio
Required-by: qiskit

Notice Version: 0.8.0, however when running qiskit.__qiskit_version__ from the Python interpreter I get the following:

{'qiskit-terra': '0.15.2', 'qiskit-aer': '0.5.2', 'qiskit-ignis': '0.3.3', 'qiskit-ibmq-provider': '0.7.2', 'qiskit-aqua': '0.7.3', 'qiskit': '0.19.6'}

Now notice 'qiskit-ibmq-provider': '0.7.2', why do I have 2 different versions running? and how can I update the python interpreter's version to 0.8.0.

NB: I only have the single (base) conda environment.

$\endgroup$
  • 1
    $\begingroup$ Maybe something went wrong with the upgrade. Try pip install qiskit --upgrade in your base environment over terminal and check if it solves the problem. $\endgroup$ – user9318 Sep 16 at 10:53
  • 1
    $\begingroup$ Thanks for the suggestion, but I already uninstalled and reinstalled Anaconda, then reinstalled qiskit with the latest versions for all subpackages. $\endgroup$ – MShakeG Sep 18 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.