3
$\begingroup$

After a successful first run without problems, I found that I cannot connect any longer.

Code:

from qiskit import IBMQ
IBMQ.load_account() #previously enabled and saved, even updated
IBMQ.providers()  # returns empty why???
provider = IBMQ.get_provider()
backend = provider.get_backend('ibmq_16_melbourne')

I re-added the token, overwrite the saved token and could successfully activate my account, but it seems that no provider can be found now. I get this error

ibmqfactory.load_account:WARNING:2020-05-25 22:08:25,390: Credentials are already in use. The existing account in the session will be replaced.
ibmqfactory._initialize_providers:WARNING:2020-05-25 22:08:29,324: Unable to instantiate provider for {'hub': 'ibm-q', 'group': 'open', 'project': 'main'}: "{'online_date': ['Not a valid datetime.']}"
ibmqfactory.load_account:WARNING:2020-05-25 22:08:29,325: No Hub/Group/Projects could be found for this account.

Even if I directly add the same hub, group and project, I am not able to retrieve a single provider. If I run IBMQ_provider() I get an empty list.

It is summarized as IBMQProviderError: 'No provider matches the specified criteria

If you could give me a had, I would be very thankful.

$\endgroup$
  • $\begingroup$ Can you see providers if you go on the IBM Quantum Expereince? $\endgroup$ – met927 May 26 at 10:35
  • $\begingroup$ Indeed, if I go to the web-dashboard I can see my past jobs. $\endgroup$ – Ruben Alfonso Casillas Pacheco May 26 at 14:36
  • $\begingroup$ I tried to access thru a web-IDE and it worked without problems. Someone knows where can I find the settings or the file in the package? $\endgroup$ – Ruben Alfonso Casillas Pacheco May 27 at 8:15
1
$\begingroup$

It is possible your credentials file has got messed up in someway. The best thing to do would be to run IBMQ.delete_account() to remove the current account details, regenerate the API token in the IBM Quantum Experience and then save this new token with IBMQ.save_account(token=new_token, overwrite=True)

| improve this answer | |
$\endgroup$
0
$\begingroup$

This is likely due to a mismatch of qiskit-terra and qiskit-ibmq-provider versions. If you're using qiskit-ibmq-provider 0.7 it requires qiskit-terra 0.14. There's a bug in qiskit-ibmq-provider's setup.py that missed this dependency.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.